Composer 10.2.1, can't delete /Users folder in snapshots

mccallister
Contributor

When trying to create packages from snapshots with Composer 10.2.1, when I select the /Users folder and say to delete it, the dialogue box that comes up with "cancel" or "delete" hangs up the computer. The app is then totally unresponsive and I have to force quit it.

I experienced this 3 times. If I use composer 10.1.1 on the same computer I have no issues deleting the users folder.

What is the cause of this and a resolution?

12 REPLIES 12

mconners
Valued Contributor

Hello @mccallister I too ran into the same thing. What I had to do was delete Composer 10.2.1 and then, go to your My Assets Page of Jamf Nation. Under the Jamf Pro listing, look for the item, show previous releases. I ended up having to revert back to 9.101 which is working perfectly well for what we need. Something is wrong with Composer 10.2.1 and I believe there is a product issue on this as well.

scottb
Honored Contributor

This thread discusses it as well. There's a new rev now, so maybe?

Composer - can't delete

mccallister
Contributor

Latest development is a redownload of 10.2.1 composer not long has that issue. But now as soon as it is launched it imediately starts doing a snap shot of the /Applications folder and never finishes.

Back to composer 9.101.4

scottb
Honored Contributor

@mccallister - Give 10.2.2 a shot? Seems so odd. Have you tried deleting everything from the left side as well as any pref's, keychain items, etc?

were_wulff
Valued Contributor II

Hey all,

Being unable to delete sources/folders is a known issue that we have filed under PI-005356.

If you have not already, please contact Support to get a case opened and attached to PI-005356.

As others have mentioned in this thread, the easiest workaround is to download an older version of Composer and use that for the time being.

Composer opening to a "snapshot" at 100% we've found to be an issue with Spotlight indexing hanging.

This thread talks about that a bit more, and the steps to fix the Spotlight issue can be found here:

https://www.technobezz.com/how-to-fix-spotlight-forever-indexing-issue-on-mac-os-x/
https://www.macissues.com/2014/07/07/fix-spotlight-continually-re-indexing-your-hard-drive/

We have not opened a Product Issue for that as it appears to be a problem with Spotlight indexing as opposed to a problem directly related to Composer.

If you have further questions about either issue, please contact Support.

Thanks!
Were Wulff
Jamf Customer Experience

scottb
Honored Contributor

Thanks, @were.wulff - that explains why it's not a global issue...

waltnerc
New Contributor II

I'm seeing this problem in 10.2.2. Tried performing the terminal commands in both URL links. Did not fix the issue for me. Very frustrated.

pvillave
New Contributor II

Composer 10.3.1 is doing the same thing. Not sure where I got this but I had though JAMF had fixed this issue already? Luckily, after force quitting Composer 10.3.1 and then opening Composer 9.100.0 I could continue where I left off. 🙂

mconners
Valued Contributor

Apparently @pvillave Jamf 10.4 has a fix for this issue. I have not updated so I can't verify. It might be worth checking out.

seann
Contributor

I have been using the Composer app from 9.101 I think. The later ones are busted. Maybe 10.4 fixed it, but haven't tried.

scottb
Honored Contributor

FWIW, I just created a couple setups using 10.4.0 and it's allowing me to delete items no problem.
I never had this issue, so this may not be of any value...

bcampbellpd
New Contributor

Confirmed fixed for me in 10.4.1, was not working in 10.3.1