Configuration profile fails on new M1 Machine with Big Sur

New Contributor

Hello Everyone,

We have a Configuration profile that is run on all machines upon provisioning, and upon enrolling my new M1 test machine, the Configuration profile in question fails with the following error: The operation couldn’t be completed. (SPErrorDomain error 10.)

Can anyone elaborate on this error? I did some research and it seems the error could be due to KEXTs not being compatible with big Sur... Anyone have insight on this?


Release Candidate Programs Tester

I've seen this as well. Same error, same answer from my research. Oddly, I've found that the config profiles ultimately do install, it just seems to take a very long time (multiple hours), and of course occurs at a time when I'm not actively investigating it, making parsing log data that much more difficult. But... no answers.
My next step is to rebuild the config profiles with the latest PPPC Utility, which has been updated to account for macOS Big Sur and use better scoping for them.


Mac computers with Apple silicon require kernel extensions to be compiled with an arm64e slice.

You can read about it here

Contributor III


We have the same problem. What is the solution ?
We can wait for days and keep restarting, but the Kernel Extensions profiles are getting into error.
Do we have to rebuild the config profiles with the latest PPPC Utility on a arm64 Mac ?

Thanks for your help

Contributor III

What version of big sur are you running? saw a whole load of kext issues on anything running older than 11.2.0

Contributor III

We have the problem on 11.2.2 and 11.2.3

New Contributor III

We are also having this issue with MacOS 11.2.3 and 11.3. Configuration Profiles which have worked in the past, are now failing, on a newly wiped M1 Macbook. Does anyone have any workaround?

New Contributor III

In my case, forcing a reboot, and/or not applying the KEXT until after a reboot helped. But I would think that wouldn't make sense in a lot of workflows.

New Contributor

I am seeing this on a small percentage of devices for a new Config Profile. Scoped to approx 1200 devices (after extensive testing) I currently have 36 showing as failed. So it can't be an error in the profile. I am hoping a comment about how it actually installs is true.