DEP synchronization failed in JAMF

New Contributor


I've seen some of you already faced that issue in the past, although the solutions that were provided didn't help in our case. Here is what we tried:
- generating new public key
- trying to upload new server token file (due to sync fail it can't connect to apple servers)
- Turning of TLSv1.3 as described in here

Unfortunately, nothing of above worked and it still shows the same notification. Any ideas? I've seen JAMF server update wasn't able to resolve the issue, we're running JAMF 10.16 with java 11.0.5.



Esteemed Contributor II

@StaplesApples Are you running a Cluster configuration? If so, open the Clustering panel in your JSS System Settings and see if the Master node is set to what it should be.

New Contributor

Actually no, we're not running cluster config.

New Contributor III

What are you hosting Jamf on?

I can't explain the why, but on Ubuntu 18.04 I was running into the same issue after taking all these steps and having our network team check the firewall until I switched to Corretto 11. I have a test instance of Jamf and both OpenJDK 11 and Java 11 failed, while Corretto 11 worked without changing anything else.

New Contributor III

Take a look at this post:

We had this problem and the issue was with TLS 1.3 being enabled on our Jamf Pro server. This article deals with disabling 1.3 on macOS and Linux, but there's a comment in the comments section that deals with how to disable it on Windows Server if that's what you're running Jamf Pro on.

EDIT: I'm an idiot who doesn't read apparently. Didn't see you mention the MacMule article somehow.

New Contributor

Yeah, I've already tried it and added the "export JAVA..." line to, our JAMF is on Redhat.