Device Signature Error

New Contributor III

Lately, every Mac that has tried to perform user-initiated enrollment in Jamf has been met with "Device Signature Error in the jamf log.

To resolve, we perform these steps:
1. Remove Jamf Framework
2. Remove Jamf CA certificate
3. Remove contents of /Library/Application Support/JAMF/Downloads/
4. Run this command: sudo update_dyld_shared_cache -force
5. Delete the mac from Jamf console
6. Run the QuickAdd package on the mac
7. Approve the Device Management Profile on the Mac
8. Assign the user to the Mac in the Jamf Pro console

This issue seems to have started with MacOS 10.14.5, but that may be coincidence. I have attached screenshots from an affected Mac. We have 3 macs that are broken right now, and 2 that were repaired using the procedure above.6548d55d08eb42868a49078c67ffc207

Anyone else seeing encountering this?


New Contributor II

Our company also experienced device signature errors while re-enrolling Macs with DEP and UIE. We worked with Jamf Support and it turns out that one of the VPP Mac apps was preventing the device certificate from installing. We excluded the VPP app from our Mac environment scope and the issue was resolved. 

View solution in original post


Something to note when using this... If you have sites, the computer object gets put into none site....


For what it's worth. What turned out to be my issue is that we were adding our management account in both the global settings (Settings Cog > User-initiated enrollment > MacOS ) AND in the pre-stage enrollment group. Once we took the management account out of the Pre-stage enrollment group, we stopped having these issues. 

This worked for me!  Thank you so much!! 

New Contributor

For this, you need to follow these steps:

1. Check Laptop "Profile" (Simply search for it if you don't find it)

2. Check CA Certificate is there or not

3. If CA is not there, go to your company's JAMF cloud manual enrolment portal.

4. Download the certificate then install this certificate from Laptop "Profile"

Then this issue will get fixed.

Valued Contributor

I just had a machine that showed the device signature error. I re-enrolled it from the command line, and it was good. It apparently updated self service and the binary too I guess, and then the device signature error returned. I re-re-enrolled it again, and it was fine after that. Weird...

New Contributor II

I was only seeing this on the M2s.  I ended up creating another PreStage but not enabling Account Settings (so no local administrator account was going to be created before Setup Assistant).  I moved the devices over to that PreStage and never got that error again.  Not sure if that is the fix but that's what worked for us.  

New Contributor III

much simpler way to fix this, as stated below.

sudo jamf enroll -prompt
wherein the JSS username and password is an account with enrolment privileges. And the SSH username and password is a local admin.