JSS 9.101.0 - iOS Self Service App - unable to connect to server

New Contributor

I updated our JSS from 9.98 to 9.101 this morning, was running through some testing and noticed that on my iPad (iOS 11) self service shows "unable to connect".

I can connect to the JSS from Safari with no certificate errors so the connectivity is there.

Any clues as to what might be causing this? I checked the ciphers on Tomcat and they are configured as per the jamf article.

<Connector URIEncoding="UTF-8" clientAuth="false" sslProtocol="TLS" sslEnabledProtocols="TLSv1.2,TLSv1.1,TLSv1" maxPostSize="-1" ciphers="TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384,TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384,                    TLS_ECDH_RSA_WITH_AES_256_GCM_SHA384,TLS_ECDH_ECDSA_WITH_AES_256_GCM_SHA384,                    TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256,                    TLS_ECDH_RSA_WITH_AES_128_GCM_SHA256,TLS_ECDH_ECDSA_WITH_AES_128_GCM_SHA256,                    TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384,TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384,                    TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA,TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA,                    TLS_ECDH_RSA_WITH_AES_256_CBC_SHA384,TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA384,                    TLS_ECDH_RSA_WITH_AES_256_CBC_SHA,TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA,                    TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256,                    TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA,TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA,                    TLS_ECDH_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256,                    TLS_ECDH_RSA_WITH_AES_128_CBC_SHA,TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA" executor="tomcatThreadPool" port="8443" protocol="HTTP/1.1" scheme="https" secure="true" SSLEnabled="true" keystoreFile="C:Program FilesJSSTomcatTomcatSSLKeystore" keystorePass="10192902500915708484">

TLS 1.0 ,1.1 and 1.2 are enabled. We're using Java 1.7 on Windows.

Any ideas on where to start troubleshooting?


Contributor III

New Contributor

Ah good spot! I just forced the update and we're good to go!

Thank you

New Contributor II

I have tried all of the above and I am still having issues, but only on some devices. I have not found any common ground on why the issue is happening.

New Contributor III

Got the first report today of this happening on iPads.

We are Cloud Hosted Jamf Pro 10.

Self Service app is updated on the iPad already.

iPads are running iOS 11.2.1

Only seeing this issue happening on 2 iPads out of 2100 so far. Hopefully this will not be widespread.

All was working as expected till today when I got the first report of Self Service not working. Just shows the Gray Unable to connect screen.


For the issues I was having with Self Service -

Doing an iOS update on the iPads resolved it for me.

New Contributor II

Still no fix for this???