MacBook Pro's shutting down in sleep

Contributor II

Hey JamfNation! hope you guys can help. I have been running into an issue where several users are reporting that when they close their macs and put them in sleep they come back the next day and it has completely shutdown. The battery is not drained and this happens when plugged into power and when its on battery. There is no power profile configured that would touch this setting the only thing I enforce is the screensaver kicking in at 15 minutes. This is becoming a large issue so any help is greatly appreciated!


New Contributor III

We are just hearing early rumblings about this. I wish I had further details.

I'm opening a ticket with Apple.

New Contributor II

Try deleting /private/var/vm/sleepimage (or mv it if you want to keep it just in case)

This was one fix that worked for us in some cases for this issue.

New Contributor III

Look into the Power Management Settings (pmset): Run this command: pmset -g It will list each arguments value, You might need to modify the "autopoweroff" argument.

Valued Contributor

This post from @emily might help determine the shutdown.

Contributor II

@shakim what should it be set to?

Contributor II

We found 2 causes for this problem:

  1. The autologout setting was causing issues. Now I run this script on every Mac we enroll into Jamf:
sudo defaults delete /Library/Preferences/.GlobalPreferences.plist
  1. Require user to unlock Filevaut 2 after hibernation setting in my Security & Privacy config profile payload was enabled, and disabling it fixed the problem. See screenshot.db766e823cef410696b8c4fe4f1f4484

hi I am a student and I have the same issue but I cannot understand your fix if you can please repeat what should I do on macOS big sur, I have an intel based MacBook Pro 2019

Valued Contributor II

I have a ticket open with apple on this.. I've sent various logs from pmset to output what's happening during sleep...

pmset -g log|grep -e " Sleep " -e " Wake " >~/Desktop/sleep.txt

We found that by turning off wifi before closing the laptop would mitigate the power drain.

10.12.5 and 6, but only on the 2016/2017 laptops (but not all of them, mine doesn't do it, nor does my lab machine, both 2016 w/ Touch Bar)

We've tried disabling power nap and wake for wifi network access... neither seemed to help.

Valued Contributor III

Worth running this to

pmset -g sched

Just to make sure it's not a scheduled event.


Do you have Bit9/Carbon Black Protect installed?

Esteemed Contributor III

Never leave home without your EAs...

Check pmset autopoweroff

# From:
#        autopoweroff is enabled by default on supported platforms as an implementation of Lot 6 to the European Energy-related Products
#        Directive. After sleeping for <autopoweroffdelay> seconds, the system will write a hibernation image and go into a lower power
#        chipset sleep. Wakeups from this state will take longer than wakeups from regular sleep.

echo "<result>$( /usr/bin/pmset -g | grep -v autopoweroffdelay | grep autopoweroff | awk '{print $2}' )</result>"

Check pmset hibernatemode

# From:
#     hibernatemode = 0 (binary 0000) by default on supported desktops. The system will not back memory up to
#   persistent storage. The system must wake from the contents of memory; the system will lose context on
#   power loss. This is, historically, plain old sleep.
#   hibernatemode = 3 (binary 0011) by default on supported portables. The system will store a copy of memory
#   to persistent storage (the disk), and will power memory during sleep. The system will wake from
#   memory, unless a power loss forces it to restore from disk image.
#   hibernatemode = 25 (binary 0001 1001) is only settable via pmset. The system will store a copy of memory
#   to persistent storage (the disk), and will remove power to memory. The system will restore from
#   disk image. If you want "hibernation" - slower sleeps, slower wakes, and better battery life, you
#   should use this setting.

echo "<result>$( /usr/bin/pmset -g | grep hibernatemode | awk '{print $2}' )</result>"

Check pmset standby

# From:
#        standby causes kernel power management to automatically hibernate a machine after it has slept for a specified time period. This
#        saves power while asleep. This setting defaults to ON for supported hardware. The setting standby will be visible in pmset -g if
#        the feature is supported on this machine.

echo "<result>$( /usr/bin/pmset -g | grep -v "standbydelay" | grep standby | awk '{print $2}' )</result>"

We saw similar things, started with EAs, and went from there.

In case you want to print out the manpage...

man -t pmset > ~/Desktop/; open ~/Desktop/

Oh, and slightly unrelated, but while you're making EAs, this one might be helpful later...

Check Powernap state

# Check if powernap is enabled or not

STATE=`pmset -g | grep powernap | awk '{ print $2 }'`

if [ $STATE = 0 ]; then
    echo "<result>PowerNapDisabled</result>"
    echo "<result>PowerNapEnabled</result>"

New Contributor III


I agree. We've got CB and it's chaos. Lots of known issues and crashing issues with the product. If you have CB reach out to your TAM.

New Contributor III

A little late to the party, but couldn't this be caused by a software update which requires a restart on a FileVault-enabled Mac?

Possible explanation:
Powernap is on. The Mac is sleeping.
A software update runs then restarts the Mac.
The Mac (booted into the recovery partition) awaits a password to unlock the volume, and receiving none, powers off.

Valued Contributor

@marc_grubb Every night?

If I understand the problem statement, we are beginning to experience the same thing here. Several laptops that used to behave one way now behave a different way - they used to sleep pretty much indefinitely, and now they appear to shut down overnight, every night, without us (intentionally) making any changes to power management settings.

New Contributor III

@JPDyson The OP did not specify every night. FileVault + PowerNap would NOT explain this behavior if it happened every night.

In my experience, this (normal) shutdown behavior on a FileVault-enabled Mac happens sporadically. The power downs could happen several weeks or months apart. Some software updates require restarts. Others don't. I haven't dug any deeper to figure out which updates caused this.

New Contributor

Hello guys,

My macbook pro started doing the shut downs for the last couple of weeks after an update of high sierra 10.13.2
I searched many things and tried many things but nothing worked out to solve the problem.

But thanks to you. I did all of the solutions here and now its fixed.

First I turned off FileVault, Then I input all these codes. And now for the last 2 days its not going into shutdown mode.

I am not a developer and don't have any idea about codes. But it worked out well and i wanna thank all of you guys.
Because I was so worried that i could have lose my macbook which i work for many projects on it.

So thanks to you all


can you send me the codes that you entered so that I can do it myself


Contributor III

I'm seeing this on my new workstation as well. it was erased and a fresh copy of 10.13.3 was installed. I seem to have a 50% chance of the Mac shutting off on lid close in stead of sleeping.

New Contributor

Solution: Download Onyx and run a Maintenance. The Spotlight index has been a disaster since El Capitan was released. This has to be done on a regular basis.

Just check your activity monitor for Spotlight energy consumption. Case closed =)

New Contributor

RogerH: any update on a solution?

New Contributor

When the "START" button is clicked, a new thread called "Thread-n" (n is a running number) is created to run the compute-intensive counting-loop. However, this thread is not programmed to yield control to other threads, in particular, the event-dispatching thread. This program is, however, slightly better than the previous program. The display is updated, and the clicking of "STOP" button has its effect after some delays. ShowBox VidMate Mobdro

New Contributor

agree. We've got CB and it's chaos. Lots of known issues and crashing issues with the product. If you have CB reach out to your TAM.
Offshorededi for offshore hosting.

Valued Contributor

@ jonybaba


New Contributor

Looks like the issue was down to public beta 10.13.1. My fix was to turn off beta downloads from the App Store, download High Sierra from the App Store and install as normal. Seems to have corrected the behavior. offshorededicated