macOS Catalina 10.15.3 update

Valued Contributor


its a big one


New Contributor II

Did this break JAMF Connect Sync for anyone else? Multiple users have reported not being able to log in because the entire process is killed and restarted the second they try to select the password field.
We're opening a support ticket but I thought it was weird that we couldn't find any mention of this online.

New Contributor III

@int-corpit Yes, we are seeing this behavior with other applications as well:

Jamf Remote/Admin
App Store > Account > View Information

We have blocked the 10.15.3 update while we investigate. We are on Jamf Pro 10.15.1 on-prem but have heard from other orgs that it is also being experienced on Jamf Pro 10.18.0 Cloud. It is not yet clear if it is related to Jamf management, such as if it is only happening when there are certain types of profiles installed.

New Contributor III

@int-corpit This appears to be caused by all versions of SentinelOne at this time. We are testing to see if whitelisting the app path resolves the issue since SentinelOne has taken up to a month to release new versions in the past.

Valued Contributor II

Current Versions of NoMad & NoMAD Login working fine for me on 10.15.3.

The only weird thing I get is this, after the computer goes to sleep / away. It displays no entered text in the password box but you can still type your password and log back in.

the whole option+return trick doesnt work.


Looking for a Jamf Managed Service Provider? Look no further than Rocketman

Virtual MacAdmins Monthly Meetup - First Friday, Every Month

Contributor II

Can verify that this issue is stemming from SentinelOne for us. We're deploying version 3.6.0.

Jamf Connect Sync 1.2.1 seemed to sign in fine but we could not log into Jamf Remote/Admin or go to App Store > Account > View Information without the app crashing. Uninstalling SentinelOne resolves the issue right away without needing to restart.

New Contributor II

Hi guys,

Facing the problem with all Jamf Suite apps, mac is on 10.15.3 and Jamf Cloud version 10.18.0. As soon as I start typing in my login credentials in Jamf Admin the software quits and throws up an "Jamf Admin Quit Unexpectedly" error.

Running SentinelOne version I'm reaching out to my security team to see if they've had any comms from S1.


New Contributor II


Response from SentineOne
"there is an issue with 10.15.3 due to changes that Apple made in their OS. We have a notification about this in our Support Portal

We are writing a fix for it and will release a formal message soon with all the details. Please ask the MAC users not to upgrade to 10.15.3 meanwhile "

New Contributor

the update to 10.15.3 definitely broke my Jamf related items. I can get into the self-service homepage however the app crashes when attempting to login. Same goes for the Jamf apps (remote, admin, composer, etc.), i can launch the apps but they immediately crash when attempting to login.

New Contributor

Hi All

Maybe has been addressed, but anybody has faced an issue after this update 10.15.3 , MS Teams Privacy ( Screen sharing) is not recognizing the change? Thoughts ?

Contributor III

@nomoprob What I'm about to say will probably sound crazy but a couple years ago I had an issue with Composer crashing on a specific version of Jamf and traced it down to having an external encrypted Time Machine drive. If that was disconnected or if I removed the encryption, Composer worked fine. If I didn't change those things but used the previous version of Composer, that version worked fine also. Jamf support couldn't explain it and even said that Composer wasn't changed between versions but they filed it as a bug. I haven't setup an encrypted Time Machine drive since that time so I don't really know if the issue was ever addressed. I figured I'd mentioned though. If you have such a drive, try disconnecting it and see if that addresses it. In my opinion it shouldn't affect it but at least in my case it certainly did.

New Contributor

@nomoprob @FChaudhri Have either of you all already submitted a ticket to JAMF regarding this issue? If so can you attach the corresponding ticket number?

New Contributor II

Hi @peguesrc, didn't need to submit a ticket as SentinelOne had already addressed that it was their issue. They've since uploaded a newer version of S1 which has fixed the issue with 10.15.3. :)

Valued Contributor

Is anyone seeing Self Service app crash using a combination of 10.15.3 and SentinelOne?

Valued Contributor II

I wonder if it has something to do with notarization finally being turned on by Apple because ever since 10.15.3 was released, I have started seeing messages on launch of a newly downloaded app that macOS can't check it for malware.

Valued Contributor

@bradtchapman I have as well so I think you've answered your own question there :)

Contributor III

So this happened on my test machine after upgrading to 10.15.3 - the management account was moved to Relocated Items folder. Anyone else see that happen on any machines?

New Contributor II

Has anyone found an update for this? After the 10.15.3 update, when attempting to launch them on my main machine they lock up to a spinning ball until force quit. What's strange is that I'm able to open Composer and any of the Jamf Suite when launching them for the first time on a new machine.
I've tried removing Full Disk Access, launching a fresh download, re-adding Full Disk Access, attempting to open Composer preferences (The entire Menu Bar locks up)

Is there some sort of permissions issue? Thanks for any suggestions!

New Contributor II

There was a huge problem with sentinel one after release of 10.15.3
But this is fixed now. All sorts of apps were crashing. Docker,.., even calendar when entering a new account. I also went up the notarisation road. But if an apple native app crashes with exactly the same behaviour you know something else is going on. Updating the sentinel one has done it. (agent 3.6.2) For the future we are blocking the Catalina updates for 90 days. (configuration profile) So on the next release we are safe and can validate on a test machine first.