NetSUS and NBI creation with Sierra

GHDJAMF
New Contributor

Hello All!

I am quite new to JAMF Nation as my organization has just signed up for Casper. I am trying to figure my way through establishing a Netboot/Netsus server and I am running into some issues in an attempt to create a netboot image (.nbi) to enable Netboot on my server. I seem to be running into this issue when I attempt to create an nbi based on Sierra.

Here's what I've got so far, I am running the latest NetSUS on Ubuntu server 14.04.
I've gone ahead and got the Install ESD of Sierra and then went ahead and created .dmg's using a couple different tools such as AutoDMG, Composer, and System Image utility. I seem to be able to make a modular dmg just fine however the problem arises when I attempt to use either Casper Netinstall Creator, AutoCasper NBI, or System Image utility to turn that dmg into an NBI.

Basically what I'm seeing is if I use NetInstall Creator it will go through the process then towards the end it went suddenly Quit unexpectedly, however it create an NBI and I'm able to deploy it to the smb share for NetSUS and the web interface see it as an nbi, however when I go to Enable Netboot it errors with Unable to Start Netboot service, Ensure your .nbi directory is properly configured. So I attempted AutoCasper instead.

With AutoCasper I am stopped before I begin. I select the dmg however when I go to select Casper Imaging it halts on "examining" and never moves part that no matter the patience given haha!

So I attempted System Image Utility as a third option and am able to create an NBI, however I'm not able to mount my dmg in there for it to create an NBI. So in an attempt to try System image utility I tried a 4th option by using an external hd created base image then see if I could create an NBI, however I was met with failure as well.

I'm kind of new at this so appreciate any help that you can provide.

Thank you!

Dustin

8 REPLIES 8

bentoms
Honored Contributor III
Honored Contributor III

@GHDJAMF If running AV, disable any on-access scanning when running AutoCasperNBI...

Also, try recreating the OS DMG in AutoDMG.

When AutoCasperNBI is "examining" it's:

When selecting an OS.dmg for the 1st time, AutoCasperNBI may appear to “hang” This is as the OS.dmg is silently mounted using hdituil attach. The reason for this can be found in the hdiutil man page: “hdiutil attach attempts to intelligently verify images that contain checksums before attaching them. If hdiutil can write to an image it has verified, attach will store an attribute with the image so that it will not be verified again unless its timestamp changes.”

So.. maybe try

hdiutil attach <path to dmg>

GHDJAMF
New Contributor

Thank you so much for the rapid response! I did attempt to create the OS DMG in AutoDMG and it created fine however the problem I have is when using that dmg or any other dmg I've created to create an NBI with the assortment of tools out there to create it. The AutoCasperNBI examining problem actually is not with the dmg I'm attaching, that mounts fine its when I go to select the Casper Imaging application that it hangs on examining.

GHDJAMF
New Contributor

Okay I was able to resolve the Casper Imaging examining issue with a fresh Casper suite install, however now I am still running into the NBI creation issue.

GHDJAMF
New Contributor

So I was able to resolve creation of an NBI however when I go to upload the NBI to my NetSUS server to enable Netboot it consistently says NBI must be configured properly. I have attempted this with a Sierra and El Capitan created NBI and still get the same thing.

bentoms
Honored Contributor III
Honored Contributor III

@GHDJAMF Ah.. AutoCasperNBI is cool.

But NetSUS is now needing NetBoot configured?

moon
New Contributor

Hey @GHDJAMF, Did you ever find a fix for "NBI must be configured properly" error when trying to enable NetBoot on the NetSUS Server? I'm seeing the same thing...

cubandave
Contributor

Hey @moon,

IDK if you are still struggling with this but is stumbled across this thread while facing the same issues.

I created my NBI with AutoCasperNBI with the nestsus setting and the OS with AutoDMG. "I did everything right" I was beating my head against a brick wall. When I discovered this:

Important: One of the subnets must include the IP address of the NetBoot server.

NetSUS Wiki

Lo and behold the Subnet & Mask I had set didn't cover the IP of the NetSUS server itself.

b39afcb409f24bf984e110b73e7ba1d7

Any who it's been forever but it you're still out there searching I hope this is what does it for you.

RobbieReichard
New Contributor III

I ran into that error message when I tried to enable the NetBoot service. I noticed I had a space in the image name so I went back and removed the space. After removing the space I tried to enable it again and got the same error. Now I verified that the IP address for the server was with-in the Subnet range. I then noticed that the Enable button was not selected. Once I selected the Enable button next to the NetBoot image it successfully launched.1d8d63bc97e34300aba023e82594d55b