Odd Behavior with Macintosh Self Service after 10.27 Jamf Cloud Upgrade

john-hsu
New Contributor III

Good Afternoon,

I was curious if anyone is experiencing odd behaviors with Macintosh Self Service after the 10.27 Jamf Cloud Upgrade. When I started my initial testing, I noticed that the Self Service application was not showing any categories. I went ahead and tried Self Service on another Macintosh, and it exhibited the same issue. After testing this on 10 systems, 7 of the systems were not showing any categories. Changing appearance from dark to light does not make any difference.

On the affected systems, it is showing all Self Service items that are scoped and I am able to run/install items from Self Service. I have already submitted a Jamf incident ticket to Jamf Support, but I thought I would see if anyone else is having an issue after the 10.27 upgrade. 99fc9e2b9f7341349c00fc16c7be2a99

48 REPLIES 48

davidi4
Contributor

the new Self Service is a disastrous mess... did they even bother to do any testing?

dulban
New Contributor III

I have the same issue on My iMac but not the MacBook Pro. Both running Big Sur.

dulban
New Contributor III

deleted

user-kvbsTlgqOz
New Contributor

is there any progress on this, im seeing it widespread at a school. I need students to download software for their classes

mark_mahabir
Valued Contributor

Jamf have confirmed that there are two Self Service category-related issues at play here - one apparently is already fixed and the other is due to be fixed before v10.28.0 is released. If you are in the Beta Program there are some discussions on those forums.

elsmith
New Contributor III

Were these issues fixed in 10.28 or 10.29?

john-hsu
New Contributor III

@elsmith Yes, I can confirm that this issue was fixed in 10.28 with Self Service.

elsmith
New Contributor III

@john-hsu Thank you!!!

kwoodard
Contributor III

I am seeing a similar issue, where some categories are not displaying, where some are. They are properly scoped (in my case, a script to update my browsers, the whole Browser category won't display in Self Service) to the machines that need this. Also, even if I tag this in the "Featured" category, it won't display. There are other items there, but not anything from the Browser category.