setting clients to use the JAMF SUS appliance

New Contributor

I have tried searching through JAMF Nation and I'm getting confused as to exactly how to point clients to the JAMF SUS appliance. I have put the DNS entry of the SUS into settings/servers/Software Update Servers and then set up a self service policy that sets that server as the system wide SUS for the client. When I go to update the software (tested across multiple operating systems) I get non-critical updates such as printer drivers and iTunes but no OS updates. If I use defaults to write the exact CatalogURL entry for the OS as per I get the correct updates showing and installing but i am trying to see how I could push this out to the clients without having to create scripts and scope them based on operating system.

any advice on this would be greatly appreciated


Contributor III

A couple of items:

  1. the default port for SUS is 8088, however, the NetSUS appliance is set for 80. Make sure you are using the right port in your url
  2. You can copy the past the url in your browser and you see data (vs. an error page)
  3. defaults read in /Library/Preferences/ CatalogURL should display YOUR URL. If blank, it's going to Apple
  4. You may not have the Browser & OS detection in your http.conf file, try adding the full path for the OS you are trying to update ( e.g. for Mt Lion use http://netsus.domain.tld/content/catalogs/others/index-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog )

- Justin

New Contributor

thanks Justin,

  1. I have used port 80
  2. I can see the general data in the browser window CatalogURL has the entry http://netsus.domain.tld/index.sucatalog (with our details)
  3. putting the full path into the plist gives us the updates but I am trying to achieve this though the settings that casper offers rather than bypassing these with a script.

I have tried putting the two different paths into a browser window. The generic http://netsus.domain.tld/index.sucatalog path shows only some of the updates (and not the 10.7.5 OS update) but putting the full path in shows all the missing pieces. It looks like it might be the browser and OS detection not working correctly. We are using version 1.02 of the netboot/SUS appliance - does anyone have any suggestions on how to test/troubleshoot this?