Content Caching is being managed by your system administrator.

Contributor III

Hello, is anyone else seeing the Content Caching pane getting locked down when applying a Restrictions payload with 'Allow Content Caching' checked?



New Contributor III

Yes. I have this same issue and it's causing me a lot of trouble.

Prior to 10.13.4, the restrictions profile with "allow content caching" checked would unlock the options in the Pref Pane, but as of 10.13.4, everything is greyed out, even with the profile installed.

I tried using terminal to set a parent (as per this article: and it actually broke the Sharing pref pane so that it wouldn't open. I had to delete the AssetCache plist & reboot in order to get the pref pane to open again, but unfortunately, this disabled caching so I had to re-enable it again...

Valued Contributor III

My experience on 10.0 is that if you have a firewall configuration profile applied then content caching is unavailable.


I had the same issue and discovered that it was being blocked by a different configuration profile. I had an energy saving config applied, and not there was no setting for content caching in it, I removed it and was able to manage content caching. Fortunately, I only permit content caching feature on my caching mac's so it was not an issue to remove the configuration profile. It was trial and error removing the profiles applied until I found which one was causing it. I had to log off and back on again for the change to take affect each change as well.

New Contributor III

So, I've tried removing all other config profiles from one of my test caching servers, and it didn't change the symptoms, even after a reboot.

The only profiles I have left on this machine are the MDM profile and the Restrictions profile (which is specifically to "allow content caching" and no other options have been changed from the default).

The other profiles that I removed were a trusted ssl certificates profile, a wireless profile and an AD binding profile, which I don't think would have interfered with this anyways.

So, at this point, I can say pretty definitively that this isn't from another profile interfering with this setting.

New Contributor II

I too have this issue, have not been able to find a way to resolve it.

Contributor III

Has anyone custom built a profile via @mm2270 method and see if it behaves? Link to custom config profiles:

New Contributor III

Found a solution there :

Valued Contributor

So awesome!

New Contributor III

@Xaviermlp - The solution you posted doesn't work on 10.13.4 & above (see my post at the top of this thread).

New Contributor III

anyone got this working after JAMF 10.9 update ?

New Contributor II

Has anyone found a solution to this? I'm trying to setup a Caching server and do not want iCloud to be cached.

Contributor III

I completely forgot about this post until I bumped into this issue again today... I'm on jamfPro 10.23.0 server with a macOS 10.15.6 client.

An admin was getting "Content Caching is being managed by your system administrator." in System Preferences despite a MDM profile with Restrictions --> Allow Content Caching being set to true.

The fix for me was to delete the allowContentCaching key pair from the MDM profile.

Perfect example of a ternary key... different behaviour in macOS for true, false, and unset. Hopefully, PI-004822 will get fixed someday.

New Contributor

We're seeing this issue in 10.23.0 as well but I am not clear on the solution that works for you Sonic84. Can you provide more info? We have multiple restriction profiles in our environment but all of them are configured to allow content caching; and while we can turn caching on, we are unable to adjust the Cache content type or Share the Internet connection as the settings are grey and we have the message "Content caching is being managed by your system administrator.

Despite the Preference settings being locked down, it seems adjustments can still be made via terminal, so if you're only concerned about disabling the iCloud portion than the command below would configure for "Only Shared", which I believe is apps & updates

sudo -u _assetcache defaults write /Library/Preferences/ AllowPersonalCaching 0

The link below has information on the associated plist;,Sharing%2C%20then%20click%20Content%20Caching.

Content Management from Command Line