Issues Using Chrome to manage JAMF


It seems the latest version of Chrome 75.0.3770.80 is causing issues with JAMF. When I try to add a package to a policy either it just spins and times out, or adds the package twice. When I delete one of those double entries, it deletes them both.

I verified this by finding a laptop that still had Chrome 74.x and it worked fine, but as soon as I updated Chrome to the latest, the issues appeared.

I am still on JAMF 10.7. so I don't know how widespread this problem may be.

For now, Safari and Firefox also work just fine.

I initially thought I had a problem with my server, so I thought I would share to help you avoid going down the wrong diagnostic path like I did.

Anyone else having an issue?


Contributor II

I saw the same behavior this morning. I added a new package before deleting the old package, saw the new one was listed twice. Deleted the old package on the new was only listed once.

New Contributor

This also happens with the latest Edge Canary builds. Something has changed in the Chromium engine that is causing this behavior.

Contributor II

Per Jamf Support:

The issue is documented on our side under PI-007099 in which the newer versions of Google Chrome cannot edit some aspects of policies.

We are aware of the issue, and are investigating it. Currently the only workaround is to use an older version of Google Chrome or use a different browser.

Valued Contributor

Same exact issue with trying to add a script to a policy.

75.0.3770.80 (Official Build) (64-bit)

Safari was my workaround.

New Contributor

Adding fuel

Seeing that same issue with Chrome Version 75.0.3770.80 (Official Build) (64-bit) on a Windows systems.

IE would not load the site at all (though that may be due to compatibility settings my org has in place).

Edge is working.

Don't currently have any other browsers installed on the system to test.

Valued Contributor

I prefer Safari. Always have since it was released as a beta app in 2003. Although I have Chrome installed on my Macs, I really don't like it very much, and it doesn't integrate with iCloud. That's a deal breaker.

Contributor III

+1 here - same issue on Chrome 75.0.3770.80

The response I got from Premium Support was "Yes, this is a known issue with Chrome 75.0.3770.80 and Jamf Pro. Please use a different browser to add items to policies for the time being. I expect this to be a temporary issue."


Same here. Chrome version 75.0.3770.90

Contributor II

Hope that everyone is reaching out to Jamf Support for visibility/impact to this issue.

Isn't going to be resolved just because you commented on this thread.

New Contributor II

We're seeing this issue too

Running Jamf Pro 10.13 & Chrome 75.0.3770.100

Support case raised with Jamf

New Contributor III

I just opened another case regarding this issue (still exists in Chrome 75.0.3770.142) and they said that it will be resolved in the 10.14 release.

Valued Contributor

I'm seeing this with Chrome on Win10. Have to use Edge. The annoying thing is that it's intermittent and Edge is quite slow to render the pages compared to Chrome.


+1 - Forced to use Safari when working within Jamf Pro.


I saw this issue affect someone taking the Jamf 200 test last week.

Valued Contributor

Works in Firefox.

Contributor II

Same here. We're advising people in our local Jamf Google group to not use Chrome (ironic though that is). I believe our lead Jamf admin has already chimed in with Jamf Technical Support on the topic, but I will double check.


Same here, main issue for us is to add scripts to policies -> timeout / infinite loading circle. Firefox works fine.

Valued Contributor II

Same issue here. I went back to Safari and it works fine.

New Contributor II

I have having issues with Chrome conflicting with Jamf Binary v 10.14...please note the following screenshot and I am now carefully removing any potentially misconfigured configuration profile...I doubt it, because there have been no issues with Chrome up until Jamf Binary 10.4 came out.

Contributor II

@jgocobachi From Jamf Support "We have an issue filed against this, and it's slated to be fixed in 10.15." Sorry, I don't yet have a PI number for this. Will repost when received.

As an aside, this has nothing to do with Google Chrome interaction. This is a symptom of Restricted Software under Jamf Pro 10.14.0.

Update: The issue number is PI-007275.

New Contributor

PI number/description, you say? This one is PI-007099.

The text of the PI:

Description Cannot Add or Delete objects to and from policies

Steps to reproduce Create a new policy and try adding: package script directory binding

Expected Results
The item is added to the policy and you are able to keep modifying the policy or save.

Actual Results When adding the script or package, the policy will spin indefinitely. After adding the directory binding, the policy reloads, but you have no options for saving/canceling.

Use another browser. Preferably Safari

As much as I personally cringe saying it, while I've had this issue happen in Chrome and Firefox, it does work fine in...Edge, which is nice as I do most of the in the GUI admin stuff from my PC so Safari wouldn't have been ideal for me.

Valued Contributor

Edge feels very slow to render the page in comparison though. Edge Chromium I think is broken in the same way.

New Contributor

Yeah, it's a little slower than Firefox, Chrome, or Safari but, with it not really working consistently in Firefox or Chrome it's sometimes my easiest option if I don't want to either work on my test computer or remote on to my main one to use Safari.


I started seeing this about a week ago, using Chrome. Switched to Firefox and it's fine.