Self service “unable to connect to server”

New Contributor

I have a connection to WiFi, however when opening the Self Service app, there is a grey bar along the top of the iPad app that says “unable to connect to server”. I have restarted the iPad several times, connected to a different WiFi network, and nothing has worked. I am unable to download apps that I need. Please help!! 5d7f4a44d1664950a0a58dfcf8aafb8d


New Contributor

I tend to see this a lot within our organization as well. The fix for me has been to delete the self service app, and then do an update inventory and once the app re-installs it works like a charm,

Please let me know if this work, thanks!

Valued Contributor II

are you self hosted or cloud hosted?

(We've ran into this problem because we use AFP & the Port isnt always open! - workaround if self hosted is to host it via http..) if cloud hosted I can't help you, know very little about that!

Looking for a Jamf Managed Service Provider? Look no further than Rocketman

Virtual MacAdmins Monthly Meetup - First Friday, Every Month

Contributor III

If the app has just installed, the managed app configuration may not have been applied yet. even if it goes through after the app is opened, once that grey bar appears at the top of the screen, as @kaliyev mentions above - have to delete the app. once the device has updated in inventory and is seen to not have self service it will install again; give it a few seconds (or check in your management tab to make sure the managed app configuration isn't still pending) and then open. you should be back in business :)

New Contributor

Make sure your Self Service app is up to date? I had that problem...

New Contributor II

I updated the app and it will not load. The only way I can get the Self Service App to load is wipe the device. Then when I open the app after spinning for 5 minutes I get the "Unable to connect to server". I have checked the firewall and tried at home and get the same result. Support says they are escalating - at this time Self Service is not working which makes using iPads difficult.

Valued Contributor

The removal of the self-service app after editing and purchasing was helpful. I was able to re-scope and re-deploy and the error of not connecting to the server is now resolved. Thank you very much for the help Nation!

@thejenbot thank you.

New Contributor

I deleted Self Service app by mistake. How Can I install the app back in my Mac OS ?

Valued Contributor

You can re-download from the Jamf Pro server in settings.

Screenshot 2023-09-21 at 2.36.37 PM.pngScreenshot 2023-09-21 at 2.41.48 PM.png





New Contributor II

late to reply to this post but I have been trying to fix this issue on an end user mac for a while now. I was able to fix this by deleting the self service certificates from keychain. I had tried removing framework and reinstalling with no luck. The cert deletion and reinstall was the fix for me