Sign into iTunes to allow "jamf......" to manage and install apps.


I have 10 iPads in front of me, all going to the same room at the same site. They are all identical, and in the same smart group receiving the same apps.

All but 1 is accepting the push. The "black sheep" if you will, is the only one displaying this error

"Sign into iTunes to allow "" to manage and install apps.

I have wiped the device, unmanaged it, deleted it, and re-enrolled it multiple times but I still get the same error. I have read other "fixes" about the app not having vpp checked but all of the other iPads are working (accepting all the apps) just fine.


New Contributor III

I had some black sheep with the same issue and same steps.. I think I did wait and the apps may finally have installed without intervention.

Contributor III

I call devices like these "Problem Childs"

New Contributor II

Try comparing the App Scope of that iPad to the other working iPads. I got that error when apps aren't installing as managed.


Yeah its definitely going into the problem pile.

The app scope is identical, from what I can tell everything is exactly the same for all 10 (which are part of a larger group of 39 that are all working fine)

I thought for sure un-managing and then re-enrolling it would for sure fix it but no luck


Ok so I took each of the two iPads and enrolled them into different groups (3 different groups each with different apps) and it gave me the iTunes error every time.

Its like the error is tied to the device and not to what I'm pushing to it.

Does that make any sense?

An answer could save the lives of two innocent iPads.


iOS version?

Release Candidate Programs Tester

@Howard.Trevor Restriction profile in place limiting installing of apps to requiring an Apple ID?


When I came back to work this morning they both had all of the apps on them. Nothing changed, no one touched anything over the weekend.

Strange... but ill take it!

Thank you all for your help!

New Contributor

I was also getting prompted to login to iTunes and finally with the help of JAMF support got it tracked down to the version of JSS I was running. Upgraded the JSS to the latest and it fixed the issue. The root of it was that some of the iPads were at iOS 10 and the older version of the JSS didn't support it. HTH.

Contributor II

Here's a thing to check that I encountered, might save time troubleshooting...

Go through your mobile app list and check for where you have applied ALL USERS as the scope. If you are doing so, that might prompt the user to sign into the App Store, YMMV. You may find this accidentally applied to your Self Service app, thus creating an initial "delay" in finalizing the initial setup of the device.

Happy hunting.

New Contributor II

After reading through all the comments/recommendations I was able to resolve the "Sign in to iTunes..." issue by going to the app --> general --> and checking the box that states "Make app managed if currently installed as unmanaged".

FYI this was for an app pushed to devices and not a download from Self Service.

New Contributor II

i keep getting message home screen on iPads , after i sent out mobile device apps: App Installation Sign in to iTunes to allow " " to manage and install apps

how to fix problem?

Contributor it's probably self service (or another app) trying to auto-install without VPP licenses. Be sure you have VPP licenses for all scoped apps, and be sure you've ticked the tiny box under the VPP tab on every single app your're scoping.

New Contributor

Under Mobile device Apps select the app you are trying to push out on to the ipad and go to managed distribution tab. Then select device assignments and under Volume content make sure the assigned content purchased in volume check box is checked.


@mpm Thanks for this common-sense reminder! It helped me remember to check if an app I was deploying was set to use VPP licenses, and it was not. Not my smartest moment, I will say.

New Contributor III


What can you do if the app that is generating the alert is from Apple. In my case iBooks... I can't associate to a VPP license

New Contributor

I fixed this issue by unchecking "Display app in Self Service after it is installed" on all of my provisioned mobile apps. We weren't pushing self service at the time so that caused jamf to loop the same error message. 

New Contributor

I fixed this by adding licenses in apple school manager. then was able to install the app.