Unable to install <app> You must purchase this app to install it

Tolandese
Contributor

This issue popped up on me in the spring and has resurfaced now as we prepare iPads for students. After setup most iPad apps install everything fine, however some devices show apps either dark or with the bullseye placeholder and say "waiting", but when you click on them you get this message:

Unable to install "Jamf Self Service"
You must purchase this app to install it
View in app store

Some of them show as installing in the system but not all. They do not process unless I manually delete every dark app and restart the iPad. This is obviously not ideal when managing large fleets, or when devices are at home with students during remote learning situations. Wondering if anyone has dealt with this issue and found a resolution. a08d2782ac134257b990dbea8466cb79

be87a3c1103346ec8648c7374ce4917e

25 REPLIES 25

atomczynski
Contributor III

Mobile Devices: Mobile Device Apps: (app): Managed Distribution

Assign Content Purchased in Volume is selected?
Location / VPP account is selected?

Tolandese
Contributor

Correct on all.

mmcallister
Contributor II

We have run into this also. Press and hold on the "dark" app and select Cancel Download. Then wait for the next inventory update (if set to Install Automatically), or install the app from Self Service. Note that this workaround requires that you have not pushed a restrictions profile to prevent app deletion.

We are not sure on the cause in our environment, but are speculating that it's related to time-of-use rules with our internet filter. During a period where internet access is disallowed on the device, the iPad checks in to JSS and gets a command to install app, but then cannot reach Apple servers to verify the license and download the app content. Apparently device communication to MDM still works when internet is blocked by our filter.

Tolandese
Contributor

That is interesting, though we do not have any such limitation set. My goal here is to avoid having to physically touch over a thousand apps as that defeats the point of remote management and it is not easy to direct hundreds of young children from home how to do this in a timely manner. I am reaching out to my rep again as I have an iPad right here that will not install apps after the deletion. It immediately gives this error and goes dark.

laurenecline
New Contributor

Edit: My initial workaround only lasted for about half of the deployments. Back to simply echoing the sentiment of experiencing the situation and not having a solution.

I am experiencing the same issue. We are pushing 10 apps from VPP and then configuring the home screen to a specific order. Interestingly, I discovered if I push all but Adobe Acrobat Reader it works exactly as expected. So I am just leaving Acrobat as a manual install from Self Service for now.

pshouston
New Contributor II

We are experiencing the same issue, has anyone found resolution from JAMF yet?

atomczynski
Contributor III

Is this a Jamf issue, or Apple issue?

At my organization we do have a restriction profile which blocks app removal as a default.

damienbarrett
Valued Contributor

I moved all my iPads from our Jamf Pro instance and into Jamf School because, after trialing it for a month, I found the interface more friendly for solving things like this. For instance, here is how I've been solving this same problem with Jamf School:
eaff62e1afac4e5a96af13bf4dc35f73

Maybe there's a similar tool in Jamf Pro for managing iPads, but I haven't found it, and have stopped looking at Jamf Pro for iPad management. I use Pro for managing our laptop fleet and School for the iPad fleet, and I'm very happy with this compartmentalization.

Sorry, I know this isn't a solution; just offering my opinion and some info. It was a PITA to have to re-enroll all our iPads into Jamf School but I'm so happy that I've done it.

atomczynski
Contributor III

@damienbarrett Wow.
This is really what's needed in Pro.

Any word if this will be ported over?

Do we know if it's an Apple sourced issue or Jamf?

JCabreraSJCA
New Contributor

I second that what atomczynski replied. Having a button to "reinstall on stuck" would be something a PRO version should have!

user-VirginiaSm
New Contributor II

I have had some success with going into the individual Devices Mobile Devices > Management
Cancel all Pending Commands
Click on Update Inventory
It has worked on some of the IPADS I'm trying to load apps too, and not others.

I was on the line with Jamf Support, and this is what we did. With kids going back to School, the Apple server is really busy, and it looks like when JAMF is trying to verify we have purchased the app, it is timing out with apple, then doesn't think we have purchased, and given the error. I'm hoping in a few days Apple is not so swamped and this works more seamlessly.

I hope this helps others.

Thank you for this!  This Worked!

sdahleen
New Contributor

I have ipads out with students, has anyone figured this out? I've only been able to work around it by erasing all content and settings with device in hand. I have hundreds of ipads out right now... and essential apps aren't working

atomczynski
Contributor III

We are handing out devices today and I'm seeing this as well with our core apps.

TexasITAdmin
New Contributor III

As we migrate devices from Meraki to Jamf and hand Jamf devices out we are also having apps not installing like this. Some of the devices are already in student's home.

I wish we had that retry feature from Jamf School in Jamf Pro.

Has anyone created a request to upvote for it yet?

atomczynski
Contributor III

I have created a FR. Please click here and upvote.

The proposed fix to disable App Store restriction, login to the App Store is not a viable solution at this time. Students are all remote.

Samplerr
New Contributor

I'm experiencing the exact same problem.

ttyler1999
Contributor

I had this problem and I was able to solve it by first canceling them on the device, and then clearing the Pending Commands in the Management tab for the affected iPad.

joif
New Contributor II

We have had this problem for quite some time, half a year or so, after restoring iPads from iCloud backup. It appears to happen in all cases, independant of network connection. We're using Jamf School, an the retry to install app un devices stuck, as previous suggested, doeas not seem to have any effect. Restricitions does not seem to be of importance, as both students and teachers experience the problem; teachers having very few restrictions, only mandatory PIN.
Cancelling installation/deleting apps is normally not an option, as apps may contain valuable data that the user want to preserve, hence the restoring from backup instead of fresh install. Also the students have a fixed layout profile, preventing normal app deletion, so requires that they know the back door for delting apps through Settings-General-iPad storage.

We have, however, found a somewhat reliable workaround procedure (but have not been able to verify if all steps are neccessary):

  1. Remove any restriction preventing account modification
  2. Perform normal restore form iCloud and enrollment
  3. Immediately go to Settings and remove/log out the Managed AppleID from AppStore (NOT logging out of iCloud)
  4. Close settings
  5. By this time some limited number of apps may actually have started downloading
  6. Wait until those few apps have finished installing, and wait a little (or eternally) to confirm that no more apps starts downloading
  7. Do not attemt opening any of those half black apps or those with a cloud symbol by the app name
  8. Perform a hard reset of the iPad (more than 10 seconds holding home and power buttons, until the apple shows)
  9. When iPad resumes, wait for the apps to start downloading/installing (seems that it may increase likelyhood of success, or at least speed up the process if an admin at this point is able to refresh the affected iPad from the Jamf School system)
  10. After all apps have installed, put back the account modification restriction profile to teh device
  11. In the few cases that the apps get stuck once more, go back to #8
  12. In the few cases that repeating #8-#11 does not do the trick, wipe the iPad and start from #2, or delete the stuck apps and ask the admin to do a couple of refresh from Jamf School (the user, or rather her teacher, can decide whats they want to do, as starting again from #2 without guarantee of success is demotivating, and deleting apps containing valuable data is a bit sad).

MarkDixon
New Contributor II

Jamf School and I have this issue as well.

Edit: To further add to this, it seems to happen when I'm setting up shared ipads, if i set up the second user before the apps have finished installing for the first user, then they're greyed out for all and will not complete.

MarkDixon
New Contributor II

Got this from the other thread linked above, might help.

Posted: 8/27/2020 at 11:59 AM CDT by jdhainley
I have also run into this issue. My solution:
1. Hold down icon until the option to Cancel Download appears and cancel download.
2. Cancel the download on all of the apps that are doing this
3. Restart the device
4. Send a Blank Push from the Management Commands to that device

Hope that helps!

sirsir
Contributor
Got this from the other thread linked above, might help. Posted: 8/27/2020 at 11:59 AM CDT by jdhainley I have also run into this issue. My solution: 1. Hold down icon until the option to Cancel Download appears and cancel download. 2. Cancel the download on all of the apps that are doing this 3. Restart the device 4. Send a Blank Push from the Management Commands to that device Hope that helps!

To piggy back on this, I've found you don't need to reboot the device. Just send the inventory update command & blank push and it will start installing.

chrisdaggett
Contributor II

@SirSir @MarkDixon Any idea why I can't get the "cancel download" option? I press and hold I get edit screen and share app, followed by jiggling icons and no menu. I ended up having to go to the scope of the app, adding the ipad as an exception, waiting for it to remove, then removing the exception. That is very unpleasant!

Tolandese
Contributor

@chrisdaggett By chance do you have those apps locked from user deletion? I ran into this again this week on one of my apps that was unchecked so students couldn't remove it and I couldn't either. Even after reenabling the option it still wouldn't allow this.

user-klJMIqIFYZ
New Contributor

If you have the Home Screen Layout payload activated then you dont have the option to cancel the download from pressing and holding the failed app. Nor do you have the option to delete the app from the Storage settings (which is currently the only method when you have HSL payload). So the simplest fix i've found is to:
1 - Exclude the problematic device from the Configuration Profile with the HSL payload.
2 - Cancel the download(s) on the device.
3 - Delete any pending apps in the Jamf History tab.
4 - Update Inventory or manually download the apps from the Self Service.
5 - Remove the Config Profile exclusion rule.

It's only happened a couple of times for us so not too much of a hassle but i wouldn't like to do it often.