VMWare Fusion - VM can't install MDM profile

New Contributor

During enrollment via URL, my VM can't install the MDM profile. The attached error is displayed.

*Profile installation failed.

The profile "MDM Profile (com.jamfsoftware.encrypted-profile-service: 00000000-0000-0000-A000-4A414D460003)" could not be installed due to an unexpected error. <NSOSStatusErrorDomain:-67701>*

The error code seems to be defined as "An invalid record was encountered", but I'm not sure what to do with that...87742118b89d4abca2f92e911ae7b0d8


Release Candidate Programs Tester

see this from @emily :)

Valued Contributor III
Valued Contributor III

@jtschaefer you need to set a hwmodel ID and make sure the VM is created with a serial number that doesn't include special characters. MDM won't work correctly if the profile is installed on a Mac without a valid (shipping) hardware model from Apple. You can check my blog post (that Ben posted above) for how to use vfuse for this, or you can create your VM and modify the vmx file within the virtual machine bundle manually before you boot it the first time. I personally recommend vfuse.

New Contributor

That did it. Thanks!

Contributor II

I am having this issue but my VM is in vCenter.
Does anyone have any tips on setting the "hwmodel ID" and machine serial in vSphere?

Contributor II

Check in your JSS that there is not a "No Name" computer or some other device that is not enrolled correctly from the dates when you first tried to enroll the VM. In my situation the first time I tried to enroll my VM and it failed it created an incomplete computer record in the JSS named "No Name". After correctly setting the MAC address, hardware info, serial number, etc. in the VM config, the VM would not enroll until after I discovered the previously created incomplete record and deleted it. After that record was deleted the VM enrolled without issue.


New Contributor III

Something that helped me in going down this path (especially with Fusion 11) was to follow Received signal 11 and Using Templates from the vfuse wiki.

Contributor II

@captam3rica First creasting a autodmg with a mojave installer and then using vfuse and running the command that both should change serial and hardware type. No error appears, but when starting up the VM the serial and mac name is still not changed

How tried to do some manuel stuff in the .VMX file in vmware fusion, but no matter what I change it does not work

Running VMware fusion 10 and also tried with 11

New Contributor II

I had no luck with this using VMware 11 when creating the vm file, error received: signal 11
Was anyone successful getting this to work with 10.4.4 and VMware 11.0.3?

Valued Contributor

This is great to know on my way to use vfuse.

Thanks @bentoms


Valued Contributor

@a.bautista Yes we've not really had a problem through multiple versions. All I do is add a line at the bottom of the .vmx file similar to:

serialNumber = hYtUInBGdWSc

i.e. a made up serial of 12 characters, none special and no quotes around them. I very rarely set a hwmodel.

Esteemed Contributor III

FWIW, to essentially sysprep a VMware virtual machine, usage:

/path/to/thisScript.sh /path/to/virtualMachine.vmwarevm/*.vmx



echo ""
echo "**********************************************************"
echo "IMPORTANT: To use this script, quit VMware Fusion first!!!"
echo "**********************************************************"
echo ""

echo "Enter your fake Serial Number for example 1234567891213."

echo "Enter ModelIdentifier for example MacBookPro11,5 or iMacPro1,1"

# Remove device specific crud

sed -i '' '/ethernet0.addressType/d' "$VMXFILE"
sed -i '' '/ethernet0.generatedAddress/d' "$VMXFILE"
sed -i '' '/ethernet0.generatedAddressOffset/d' "$VMXFILE"
sed -i '' '/uuid.bios/d' "$VMXFILE"
sed -i '' '/uuid.location/d' "$VMXFILE"
sed -i '' '/hw.model/d' "$VMXFILE"
sed -i '' '/serialNumber/d' "$VMXFILE"

# Add Model Identifier and Serial Number

echo "hw.model = $MODELIDENTIFIER" >> "$VMXFILE"
echo "serialNumber = $SERIALNUMBER" >> "$VMXFILE"

exit 0

New Contributor III

Doing a quick browse through these answers, I'm seeing a lot of mentions that you need to add a hardware model and a serial number to the vm, but I'm not seeing anyone say how to do it. For visibility, in VMWare Fusion 8:

In the vm library view, right click on the vm you want to add this information to, then hold option while the right click menu is open. This should give you the option to Show Config File in Editor. In the config file, add the lines

hw.model = "<insert hardware model here>"
serialNumber = "<insert serial number here>"

Valued Contributor II

@aalberty I just switched to VMware Fusion from Parallels. Thanks for this tip. I have decided that Parallels is crap. It's crap coated crap with crap filling and it runs like crap on macOS Big Sur.


I'm seeing this same error but on physical hardware. It's happening post migration to Jamf Cloud. Any thoughts? I've got a ticket open with Jamf Support, but thought I'd ask here too.