Microsoft Word and Excel Errors, opening, saving, etc. - HELP!


We are experiencing a suite of odd and frustrating errors with Office products on our Macs. It started off small and has soon spread throughout our school district. The some of the most common errors are:

With this error there were no other files open, or often only one or two files.

With this file, it had been used by multiple users prior to this. And as you can see from the name it is a simply a normal .docx

The AutoRecover problems happen quite a bit. The user has perfectly normal permissions and if the file is quit out of the user will be able to reopen it and use it for a period of time until this again occurs.

The files here are never read only and in fact exist in various locations (the users Desktop, Documents, Google Drive and other folders), all of which are available and are not read-only.

Also, at the time of this posting a system we were testing had the AutoRecovery error but had no files open at all during that time, just Word. It appears that the error was for a file that had been closed some 10 minutes earlier.

We have been racking our brains on this. Some of the things we have tried include:
Restarting - Stops for a time, but returns
Repairing Disk Permissions - Stops for a time, but returns
Reimage the system - Stops for a time, but returns (This is primarily the same image, with updates, we have been using since August
Dumping all plists, cache files, ByHostfiles, temp files and resetting Office for the user - Stops for a time, but returns
Reinstall Office - Stops for a time, but returns
Updating to the latest and greatest release of Mavericks and Office- Stops for a time, but returns
Checked creator code - everything is normal
Looked for any errors in console - many times literally nothing populates, other times the only error that is occurs is - 4/30/15 1:22:37.021 PM xpcd[26926]: Info.plist does not contain an XPCService dictionary: /System/Library/Frameworks/Security.framework/XPCServices/SecurityAgent.xpc - with varying date and times obviously

We are running out of ideas. We are focusing on Casper as a factor since it is definitely the common denominator. The systems that have experienced it all have the framework installed. That may not be the framework's fault, it could just mean that something that has been pushed out, updated, etc. through Casper may be causing the issue. Any thoughts are welcomed!


New Contributor III

Curious what happens if you opt to reimage a computer and avoid the MS Office install. Instead, install MS Office after imaging from download.

Honored Contributor II
Honored Contributor II


From what I've seen I don't think Casper in itself would cause this. With regards to pushing things out, that could be endless possibilities.

The main things that spring to mind first are:

  • How may Macs are you talking about here? Microsoft Office on the Mac is a buggy bit of software so if you have 10,000 devices, a few failures isn't really that bad.
  • Are you using local home folders? Where are the files being saved? Most of the common crashes and bugs that occur in MS Office can be multiplied many times over when the files are being opened, edited and saved from a network drive.
  • Are all the software versions consistent? If users with slightly different software versions are working on the same files, this could cause more problems.

Esteemed Contributor III

Are the users' home directories on the server?



To answer some of the questions. The home folders are local, and created with local templates. AD is being used for permissions and authentication only. We have about 2,000 users and the versions are consistent. At the moment I would say easily 1/2 have experienced this issue and that percentage is climbing.

evanmellichampe, I had tried that as well, but forgot to include it in my list in this post.

One thing that has come to light and that we are currently testing is that we had been running a Maintenance Policy that performed the following function for users Once a Week - Fix Disk Permissions; Fix ByHost Files; Flush System Caches; Flush User Caches.

One of our Techs has been looking in to it and we started to focus on the ByHost files. Currently we have disabled the Maintenance Policy and have made a Self Service Repair Policy that flushes out the ByHost folder and restarts the system. We have done it to a handful of systems today and are waiting to see the results of them before we try it on anyone else.

Legendary Contributor III

Were you rebooting the Macs after flushing all those cache files as a standard part of that original maintenance policy? If not, this could possibly explain why the errors stopped after doing a reboot but returned again (after the policy ran again). Flushing that many cache files should be followed up immediately with a full system reboot to avoid odd behavior in my personal experience.

Before you posted, I was going to suggest to you that as soon as the problem resurfaced on a Mac, look that mac up in your JSS, go into the details, then History, and then look at the Policy logs to see what recently ran on that Mac. I do think something is running against your Macs that is causing it, and it could very well have been that maintenance policy.