LLVM Profile Error: Failed to write file "default.profraw": Read-only file system - Deploy Command

Punjabiwifi
New Contributor

After the upgrade to MacOS 12.3, the Jamf login screen went away, i found that running this command would fix the issue : 

/usr/local/bin/authchanger -reset -jamfconnect

Although after creating a policy and trying this through execute command i get the following error:

LLVM Profile Error: Failed to write file "default.profraw": Read-only file system

 

I tried the command in terminal manually with sudo permissions and it did work. 
How can i fix it ? 

15 REPLIES 15

joshuaaclark
New Contributor III

Executing the command via Jamf policy, I also got this as a script result.

 

Hi Joshuaaclark, thanks for helping me out. I have created a new policy and added the above command under Execute Command in Files and Processes. Is that what you meant ? because i still get the error.
What am i doing wrong here ?


joshuaaclark
New Contributor III

No solution. I was posting here to say I am having the same issue. I am also looking for help.

 

Kreegs
New Contributor

Same here.  Applied the policy but getting the "LLVM Profile Error: Failed to write file "default.profraw": Read-only file system" error

MaryDuffy
New Contributor

Also receiving this on a few macbooks after upgrading to Monterey.

Steven_Xu
New Contributor III
New Contributor III

same here.

Kyle-Johnston
New Contributor

Any one find a fix? 

 

Im getting this as well 

skedaddle
New Contributor

Unfortunately, we ran into this issue with a Macbook from 2017 updating to Monterey. We ended up having to try the following in Recovery Mode to disable JAMF connect. 

JAMF Docs 

the link you posted does not work...

Thank you.

n123
New Contributor

Faced the same with Jamf Connect v 2.5.0, so I'd suggest you to check yours and update if possible.

It was fixed in a Jamf Connect v 2.8.0:
https://docs.jamf.com/jamf-connect/2.8.0/documentation/Release_History.html

markopolo
Contributor

I'm getting this too, with Jamf Connect 2.16 installed on 12.6.1. Anyone have a solution? I'm just trying to reset authchanger to default (no Jamf Connect) for some testing.

stu_ross
New Contributor

I am also getting this with Jamf Connect 2.16 installed on 12.5.1

cmoran
New Contributor II

We saw this error but upgrading to 2.17 resolved it. 

I just got this on 2.17.0 trying to reset authchanger to Jamf Connect.

memile
New Contributor

Same.. Just pushed v2.17 and have seen this in the deployment logs. Does it affect any functionality?