[OT] Create User Pkg

Valued Contributor II

I am using the CreateUserPkg (v1.2.3) from the app store to create a hidden local admin account. What we are finding is that if we sign in under that local account, we get missing application "?" in the dock and we cant save to the desktop. Domain accounts and the casper account are fine, just this one we are creating with the CUP. I saw on the git that there's a 1.2.4 version out, but I only have an IOS dev account, so I can't build a new package, and the MAS only has 1.2.3.

Does anybody know how to get around the problem with the account mentioned above?



I'm not sure which version is offered, but the Instadmg download (at google code) has CreateUser within it's add-on folders.

Maybe it has what you need.
I've seen the none functional dock item, but never thought it was createuser related.
I've not seen it since upgrading to 10.8, but I also used a newer create user to compile that image.

Valued Contributor

"I saw on the git that there's a 1.2.4 version out, but I only have an IOS dev account, so I can't build a new package,"


Xcode is available for free on the Mac App Store; that's all you need to build CreateUserPackage from the GitHub repo.

And: have you created an issue here: https://github.com/MagerValp/CreateUserPkg/issues?state=open

Per also has listed his email address in the GitHub README...


jwojda - You're missing your home folder. At least everytime that's happened to me that was the issue. Look into when you are running the create user package.

Edit: Actually it could also be a permission issue as well now that I think about it.

Valued Contributor II

@Greg, I tried to launch the project in xcode, but because I don't have a Mac Dev account, I don't have a provisioning profile/code signing identity... and now that I'm looking at it again, I can just select "none" :)

I got it built and am testing a new package now :)


Is it possible to use this with a pre-configured user account that I have in a .dmg (dock and finder preferences set) ?



Valued Contributor


Any chance that this was working fine for you previously, and your only now having this problem with JSS 8.71?

I've recently upgraded and I'm now seeing something very similar where suddenly my local admin account (package made with CreatUser) home folder is whacked, looks like the folder set from the UserTemplate is not fully populating and then my prefs don't save. It's ugly.

Valued Contributor II

I'm on 9.12 currently, and I don't think it ever worked right. It seems to be okay now though.


@corbin3ci yes, this can essentially overwrite the user's record in the local directory service and therefore make reference to a new password, the only thing to be aware of is that the UID should match to avoid collisions with other users that for whatever reason may have the same UID as your newly created pkg.

New Contributor


Did you ever find a solution to this?

Valued Contributor

@robert_marking No, in that case I didn't figure it out. It only occurred on one of several imaging configs.
I simply adjusted the Imaging Config management account to be my standard admin account.

I've been happily using CreateUser for other purposes since then without issue.